13 C
London
Tuesday, May 21, 2024

ios – CocoaPods not put in or not in legitimate state. Flutter


Hey I noticed this issus has confronted others earlier than and have some query and solutions can be found. However neither answer that point out not labored right here

Launching lib/main_stage.dart on iPhone 15 Professional in debug mode...
Warning: CocoaPods is put in however damaged. Skipping pod set up.
  You seem to have CocoaPods put in however it's not working.
  This could occur if the model of Ruby that CocoaPods was put in with is completely different from the one getting used to invoke it.
  This could normally be fastened by re-installing CocoaPods.
To re-install see https://guides.cocoapods.org/utilizing/getting-started.html#set up for directions.

CocoaPods not put in or not in legitimate state.
Error launching utility on iPhone 15 Professional.

flutter physician -v

[✓] Flutter (Channel steady, 2.10.5, on macOS 14.4.1 23E224 darwin-arm, locale en-LK)
[!] Android toolchain - develop for Android gadgets (Android SDK model 34.0.0)
    ✗ Android license standing unknown.
      Run `flutter physician --android-licenses` to simply accept the SDK licenses.
      See https://flutter.dev/docs/get-started/set up/macos#android-setup for extra particulars.
[!] Xcode - develop for iOS and macOS (Xcode 15.3)
    ✗ CocoaPods put in however not working.
        You seem to have CocoaPods put in however it's not working.
        This could occur if the model of Ruby that CocoaPods was put in with is completely different from the one getting used to invoke it.
        This could normally be fastened by re-installing CocoaPods.
      To re-install see https://guides.cocoapods.org/utilizing/getting-started.html#set up for directions.
[✓] Chrome - develop for the net
[!] Android Studio (model 2023.3)
    ✗ Unable to search out bundled Java model.
[✓] VS Code (model 1.89.1)
[✓] Related gadget (2 out there)
    ! Error: Searching on the native space community for Dinesh's iPhone. Make sure the gadget is unlocked and connected with a cable or related to the identical native space community as this Mac.
      The gadget have to be opted into Developer Mode to attach wirelessly. (code -27)
    ! Error: Searching on the native space community for Saberion’s iPhone. Make sure the gadget is unlocked and connected with a cable or related to the identical native space community as this Mac.
      The gadget have to be opted into Developer Mode to attach wirelessly. (code -27)
[✓] HTTP Host Availability

I’ve tried

  • flutter clear
  • flutter pub get
  • flutter run
  • android studio invalidate clear
  • sudo gem uninstall cocoapods && sudo gem set up cocoapods
  • open android studio on command line “open /Functions/Android Studio.app”
  • restart IDE, Editor
  • Restart laptop computer
  • create iOS folder individually

And in addition
I can run this utility on android
Can run different Flutter Undertaking
And dosen’t change any configuration on cocopods

Latest news
Related news

LEAVE A REPLY

Please enter your comment!
Please enter your name here