6.7 C
London
Tuesday, October 31, 2023

ios – get uncuaght error new nativeeventemitter required non null agument


Now i making an attempt construct app React native in Android and IOS
Every thing work good in ANDROID however when i making an attempt run IOS efficiently after the appliance present me efficiently

enter image description here

enter image description here

when i click on login it work good and after that it present me error ” get uncaught error new nativeeventemitter required non null argument .
Please assist to do repair it

my package deal.json

"scripts": {
    "android": "react-native run-android",
    "ios": "react-native run-ios",
    "lint": "eslint .",
    "begin": "react-native begin",
    "check": "jest"
  },
  "dependencies": {
    "@notifee/react-native": "^7.7.1",
    "@react-native-community/datetimepicker": "^7.0.1",
    "@react-native-community/geolocation": "^3.0.6",
    "@react-native-community/masked-view": "^0.1.11",
    "@react-navigation/bottom-tabs": "^6.5.7",
    "@react-navigation/drawer": "^6.6.2",
    "@react-navigation/material-bottom-tabs": "^6.2.15",
    "@react-navigation/native": "^6.1.6",
    "@react-navigation/native-stack": "^6.9.12",
    "@react-navigation/stack": "^6.3.16",
    "axios": "^1.4.0",
    "lodash": "^4.17.21",
    "second": "^2.29.4",
    "react": "18.2.0",
    "react-datepicker": "^4.11.0",
    "react-native": "0.71.7",
    "react-native-custom-refresh-control": "^1.0.5",
    "react-native-datepicker": "^1.7.2",
    "react-native-elements": "^3.4.3",
    "react-native-flash-message": "^0.4.1",
    "react-native-gesture-handler": "^2.9.0",
    "react-native-gradle-plugin": "^0.71.19",
    "react-native-image-picker": "^5.3.1",
    "react-native-maps": "^1.6.0",
    "react-native-maps-directions": "^1.9.0",
    "react-native-material-menu": "^2.0.0",
    "react-native-modal-datetime-picker": "^15.0.0",
    "react-native-onesignal": "^4.5.1",
    "react-native-paper": "^5.7.0",
    "react-native-push-notification": "^8.1.1",
    "react-native-reanimated": "^3.1.0",
    "react-native-safe-area-context": "^4.5.1",
    "react-native-screens": "^3.20.0",
    "react-native-splash-screen": "^3.3.0",
    "react-native-vector-icons": "^9.2.0"
  },
  "devDependencies": {
    "@babel/core": "^7.20.0",
    "@babel/preset-env": "^7.20.0",
    "@babel/runtime": "^7.20.0",
    "@react-native-community/eslint-config": "^3.2.0",
    "@tsconfig/react-native": "^2.0.2",
    "@sorts/jest": "^29.2.1",
    "@sorts/react": "^18.0.24",
    "@sorts/react-test-renderer": "^18.0.0",
    "babel-jest": "^29.2.1",
    "eslint": "^8.19.0",
    "jest": "^29.2.1",
    "metro-react-native-babel-preset": "0.73.9",
    "prettier": "^2.4.1",
    "react-test-renderer": "18.2.0",
    "typescript": "4.8.4"
  },
  "jest": {
    "preset": "react-native"
  }

Latest news
Related news

LEAVE A REPLY

Please enter your comment!
Please enter your name here