12.7 C
London
Sunday, May 19, 2024

ios – How one can resolve Invalid ‘expo-dev-launcher.podspec’ file: undefined methodology ‘add_dependency’ for Pod:Module in React Native venture


I get the error

Invalid Podfile file:
Invalid expo-dev-launcher.podspec file: undefined methodology `add_dependency’ for Pod:Module.

when I attempt to do pod set up. The error is within the file [MyAppProjectName]/node_modules/expo-dev-launcher/expo-dev-launcher.podspec

I’ve tried putting in expo-dev-launcher to see if that would supply the tactic that this file is searching for and various different issues. I’ve additionally tried commenting out that line, however then it bumped into the identical error in one other file the place the file was utilizing add_dependency(), however the error mentioned once more that that methodology was undefined.

Possibly I’m lacking a dependency or one of many dependencies must be a special model?

Finally, I’m attempting to create a neighborhood growth construct of my app.

Listed below are my dependencies in my bundle.json file:

 "dependencies": {
    "@babel/preset-env": "^7.24.5",
    "@babel/runtime": "^7.24.5",
    "@expo/config-plugins": "^8.0.4",
    "@expo/prebuild-config": "^7.0.4",
    "@react-native-masked-view/masked-view": "0.3.1",
    "@react-navigation/bottom-tabs": "^6.5.11",
    "@react-navigation/native": "^6.1.9",
    "@react-navigation/native-stack": "^6.9.17",
    "@react-navigation/stack": "^6.3.20",
    "apisauce": "^3.0.1",
    "core-js": "^3.35.1",
    "expo": "^49.0.0",
    "expo-app-loading": "^2.1.1",
    "expo-constants": "~16.0.1",
    "expo-dev-client": "~4.0.14",
    "expo-dev-launcher": "^4.0.15",
    "expo-dev-menu": "^5.0.14",
    "expo-font": "~12.0.5",
    "expo-modules-autolinking": "^1.11.1",
    "expo-secure-store": "~13.0.1",
    "expo-splash-screen": "~0.27.4",
    "expo-status-bar": "~1.12.1",
    "firebase": "^10.7.1",
    "formik": "^2.4.5",
    "jwt-decode": "^4.0.0",
    "react": "18.2.0",
    "react-native": "^0.72.10",
    "react-native-device-info": "^10.12.0",
    "react-native-flipper": "^0.212.0",
    "react-native-gesture-handler": "~2.16.1",
    "react-native-google-mobile-ads": "^13.3.0",
    "react-native-reanimated": "~3.10.1",
    "react-native-safe-area-context": "4.10.1",
    "react-native-screens": "3.31.1",
    "yup": "^1.3.3"
  }

Latest news
Related news

LEAVE A REPLY

Please enter your comment!
Please enter your name here